Wróć   polish:Elite:board > hard- i software > programy
programy dyskusja, pomoc, bez ofert

Odpowiedz
 
LinkBack Narzędzia wątku Przeszukaj ten temat Wygląd

  #1 (permalink)  
Stare 02.01.2010, 16:28
Junior Member
 
Zarejestrowany: Nov 2009
Postów: 32
Postów w giełdzie: 0
Domyślnie Excel - Instrukcja warunkowa (Jeżeli+Oraz)

Witam ! Potrzebuję zagnieździć dwie instrukcje warunkowe tego typu:

=JEŻELI.BŁĄD(A1*A2;"brak") LUB JEŻELI(B1>C1;"gratulacje")

No i mam problem jak zagnieździć te dwa warunki .

Za pomoc dziękuje

  #2 (permalink)  
Stare 03.01.2010, 20:08
Senior Member
 
Zarejestrowany: Dec 2007
Postów: 123
Postów w giełdzie: 0
Domyślnie Odp: Excel - Instrukcja warunkowa (Jeżeli+Oraz)

Napisz więcej co chcesz uzyskać bo wprowadziłeś sporo zamieszania w pytaniu, piszesz w temacie (Jeżeli + Oraz) a poniżej w formułach pojawia się LUB.
Co ma być wynikiem formułu jeśli A1*A2 nie jest błędem i jednocześnie B1>C1 jest prawdą? ba być "brak" czy "gratulacje" bo na coś trzeba się zdecydować.

  #3 (permalink)  
Stare 04.01.2010, 15:47
Avatar Gorion103
Senior Member
 
Zarejestrowany: Aug 2008
Postów: 232
Postów w giełdzie: 0
Domyślnie Odp: Excel - Instrukcja warunkowa (Jeżeli+Oraz)

Napisz o co ci chodzi
Albo przeczytaj poradnik microsoftu

Składnia - JEŻELI(test_logiczny;wartość_jeżeli_prawda;wartość_jeżeli_fałsz)
http://office.microsoft.com/pl-pl/ex...091181045.aspx
__________________
AMD Phenom x4 9850 // 2GB DDR2 1066Hz // Sapphiere Radeon 5830 HD <- 4870 TOXIC spalona // Gigabyte MA78GM-S2H // Cooler Master RS-460-PCAP-A3 460W
Tak na prawdę to jestem dupa i na się nie znam ale ciii...

  #4 (permalink)  
Stare 04.01.2010, 20:16
Junior Member
 
Zarejestrowany: Nov 2009
Postów: 32
Postów w giełdzie: 0
Domyślnie Odp: Excel - Instrukcja warunkowa (Jeżeli+Oraz)

Trochę pokręciłem, więc pokaże o co mi chodzi :

No i nie mam pojęcia jak ukryć żeby nie pokazywało tego "brak" tam gdzie zaznaczone. Dzięki za pomoc

  #5 (permalink)  
Stare 04.01.2010, 21:59
Senior Member
 
Zarejestrowany: Dec 2007
Postów: 123
Postów w giełdzie: 0
Domyślnie Odp: Excel - Instrukcja warunkowa (Jeżeli+Oraz)

Nie do końca wiem jaka jest formuła w D6 bo wynik z formuły w niebieskiej ramce wychodzi inny, ale może zrób to tak:


C6: =B1
D6: =JEŻELI(C6<>"";PIERWIASTEK(C6^4+4*C6^2-25*C6-28);"")
C7: =JEŻELI(CZY.BŁĄD(JEŻELI(C6+$B$2<$B$1+$B$3*$B$2;C6+$B$2;""))=PRAWDA;"";JEŻELI(C6+$B$2<$B$1+$B$3*$B$2;C6+$B$2;""))
D7: =JEŻELI(C7<>"";PIERWIASTEK(C7^4+4*C7^2-25*C7-28);"")

Pozbywasz się w ten sposób kolumny pomocniczej E, oraz problemu z "brak"iem.

Pozdr

  #6 (permalink)  
Stare 04.01.2010, 22:08
Junior Member
 
Zarejestrowany: Nov 2009
Postów: 32
Postów w giełdzie: 0
Domyślnie Odp: Excel - Instrukcja warunkowa (Jeżeli+Oraz)

Cytat:
Napisał gajowy12 Zobacz post
Nie do końca wiem jaka jest formuła w D6 bo wynik z formuły w niebieskiej ramce wychodzi inny, ale może zrób to tak:


C6: =B1
D6: =JEŻELI(C6<>"";PIERWIASTEK(C6^4+4*C6^2-25*C6-28);"")
C7: =JEŻELI(CZY.BŁĄD(JEŻELI(C6+$B$2<$B$1+$B$3*$B$2;C6+$B$2;""))=PRAWDA;"";JEŻELI(C6+$B$2<$B$1+$B$3*$B$2;C6+$B$2;""))
D7: =JEŻELI(C7<>"";PIERWIASTEK(C7^4+4*C7^2-25*C7-28);"")

Pozbywasz się w ten sposób kolumny pomocniczej E, oraz problemu z "brak"iem.

Pozdr
Masz rację, w D6 ta formuła licząca ma znacznie dłuższą postać, ale chciałem jedynie dać zarys co w niej siedzi... i ją skróciłem po przekopiowaniu....

Zaraz spróbuje sposobem co napisałeś.

EDIT. Coś jednak nie działa... metoda którą napisałeś . Wynik w D6 i D7 jest taki sam, a tak być nie powinno. Poza tym wydaje mi się, że kolumna pomocnicza jest potrzebna (dzięki niej tworzę odpowiednią liczbę wierszy podaną w tabeli "ILE WIERSZY"). Właściwie to co do tego mój wykładowca powiedział że jest ok, i dał mi wskazówkę żeby stworzyć sobie jeszcze jakąś kolumnę pomocniczą i dać warunek dzięki któremu, pozbędę się tego "BRAK" tam gdzie nie powinno go być. Próbowałem coś typu : JEŻELI(C11="";D11="") tyle że warunek zwraca wartość logiczną... więc nie wiem czy w ogóle w dobry sposób kombinuje i gdzie ewentualnie umieścić/zagnieździć jeszcze ten warunek sprawdzający...

  #7 (permalink)  
Stare 06.01.2010, 20:44
Senior Member
 
Zarejestrowany: Dec 2007
Postów: 123
Postów w giełdzie: 0
Domyślnie Odp: Excel - Instrukcja warunkowa (Jeżeli+Oraz)

Jak wynik w D6 i D7 może być równy skoro formuły odwołują się do komórek odpowiednio C6 i C7 (w których są różne liczyby). Kolumna pomocnicza może być ale nie musi, ja podałem Ci przykład rozwiazania gdzie nie jest ona niezbędna (i tak samo funkcje generują odpowiednią liczbę wierszy)

Łopatologia:
http://uploading.com/files/8e78cf29/...opatologia.xls

Napisz co Ci nie działa???

Pozdr

  #8 (permalink)  
Stare 06.01.2010, 21:12
Junior Member
 
Zarejestrowany: Nov 2009
Postów: 32
Postów w giełdzie: 0
Domyślnie Odp: Excel - Instrukcja warunkowa (Jeżeli+Oraz)

Cytat:
Napisał gajowy12 Zobacz post
Jak wynik w D6 i D7 może być równy skoro formuły odwołują się do komórek odpowiednio C6 i C7 (w których są różne liczyby). Kolumna pomocnicza może być ale nie musi, ja podałem Ci przykład rozwiazania gdzie nie jest ona niezbędna (i tak samo funkcje generują odpowiednią liczbę wierszy)

Łopatologia:
http://uploading.com/files/8e78cf29/...opatologia.xls

Napisz co Ci nie działa???

Pozdr
A no o to mi chodzi:

  #9 (permalink)  
Stare 06.01.2010, 21:16
Senior Member
 
Zarejestrowany: Dec 2007
Postów: 123
Postów w giełdzie: 0
Domyślnie Odp: Excel - Instrukcja warunkowa (Jeżeli+Oraz)

I wszystko teraz jest jasne
w D6 wpisz:

=JEŻELI(C6="";"";JEŻELI(CZY.BŁĄD(PIERWIASTEK(C6^4+4*C6^2-25*C6-28))=PRAWDA;"brak";PIERWIASTEK(C6^4+4*C6^2-25*C6-28)))

i oczywiście skopiuj w dół.

  #10 (permalink)  
Stare 06.01.2010, 21:34
Junior Member
 
Zarejestrowany: Nov 2009
Postów: 32
Postów w giełdzie: 0
Domyślnie Odp: Excel - Instrukcja warunkowa (Jeżeli+Oraz)

Cytat:
Napisał gajowy12 Zobacz post
I wszystko teraz jest jasne
w D6 wpisz:

=JEŻELI(C6="";"";JEŻELI(CZY.BŁĄD(PIERWIASTEK(C6^4+4*C6^2-25*C6-28))=PRAWDA;"brak";PIERWIASTEK(C6^4+4*C6^2-25*C6-28)))

i oczywiście skopiuj w dół.
No i o to chodziło Dzięki wielkie za pomoc . Masz u mnie browar
Odpowiedz

Szybka odpowiedź
Antispam, complete the task: 
 
Wiadomość:
Opcje

Narzędzia wątku Przeszukaj ten temat
Przeszukaj ten temat:

Zaawansowane wyszukiwanie
Wygląd

Zasady postowania
Nie możesz zakładać nowych tematów
Nie możesz pisać wiadomości
Nie możesz dodawać załączników
Nie możesz edytować swoich postów

BBCode jest Włączony
EmotikonyWłączony
[IMG] kod jest Włączony
HTML kod jest Wyłączony
Trackbacks are Wyłączony
Pingbacks are Wyłączony
Refbacks are Wyłączony


Podobne wątki
Temat Autor wątku Forum Odpowiedzi Ostatni post/autor
[EXCEL] Funkcja JEŻELI razrone programy 47 22.11.2013 00:08
Excel-funkcja jeżeli xk4l1x programy 5 05.03.2011 18:37
Excel 2003 SUMA.JEŻELI emonkey programy 7 22.06.2010 20:27
[Excel] mały problem z formułą 'jeżeli' bulwa11 programy 4 30.09.2009 04:01
Microsoft Excel - zadanko z formuła "jeżeli" i nie tylko :) patryk898 programy 0 26.02.2008 19:14


Wszystkie czasy w strefie GMT +2. Teraz jest 09:44.

Powered by vBulletin® Version 3.8.8 Beta 3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.5.2
Tłumaczenie: vBHELP.pl - Polskie wsparcie vBulletin
1414223087

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345